Resolved
Service has returned to normal and the incident is now closed. Thank you for your patience.
Investigating
We are experiencing a service disruption affecting lead qualification. Some leads may be incorrectly marked as inconclusive. Our team is actively working on a resolution.
Investigating
We are experiencing a service disruption affecting lead qualification. Some leads may be incorrectly marked as inconclusive. Our team is actively working on a resolution